Support for Hadoop 0.19 and 0.18 Releases

With the push of the Cascading 1.0.6 maintenance release today, we also added official support for both Hadoop 0.19.0+ and Hadoop 0.18.3+ releases.

That is, you can run any maintenance version of Hadoop 0.19, or any maintenance version of Hadoop 0.18.3 and above without any code changes to your Cascading application. Both libraries are API compatible and can be used interchangeably.

Do note that if your application sets any properties specific to a given Hadoop version, they may not be recognized, but this is generally unlikely.

Visit our downloads page for all available releases.